برای ارائه سازگاری به عقب برای ویژگی های جدید  در آندروید، گوگل به طور مرتب مجموعه ای از کتابخانه ها تحت عنوان AppCompat پشتیبانی می کند که توسعه دهندگان می توانند در برنامه خود ادغام کنند. علی رغم اینکه هیچ خطای در کد اپلیکشن اندریدم وجود ندارد خطای ذکر شده  از کلاس AppCompat در لاگ کت نشان می دهد در این پست نحوی رفع آن را بررسی خواهم کرد.

خطای کامل اندروید:

07-12 08:19:55.981 25754-25754/xyz.stackprogramer.stackdesign.stackdesign E/dalvikvm: Could not find class ‘android.graphics.drawable.RippleDrawable’, referenced from method android.support.v7.widget.AppCompatImageHelper.hasOverlappingRendering

برای رفع مشکل باید مینیمم اس دی کی را برای پروژه ای پی ای بالای 19 مثلا 20،21،…بگذاریم مشکل حل خواهد شد. ولی شبیه ساز اندرید من بلواستکس ای پی ای 19 است، اون وقت نمی تونم برنامه ام را دبیاگ کنم.

بلواستکس بنده ورژن 1 بود آن ره به بلواستکس  3 اپدیت کردم حالا این شبیه ساز اندروید 7 می باشد. که با تغییر مینیمم ورژن اس دی کی مشکل حل شده است.

بلو استکس 3شکل1: محیط بلواستکس 3

Tags: , , , , , , , , , , , , , , , , , ,


Leave a Reply

Your email address will not be published. Required fields are marked *